EnterpriseDB: The Enterprise Postgres Company Postgres Plus Forums: The PostgreSQL Open Source Database from EnterpriseDB
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [Groups] Back to home page 

Postgres 8.4 - PL/pgSQL Debugger "missing"  XML

Forum Index » PostgreSQL Installers for Windows, Linux and OS X
Author Message
Stefan_W

New member

Joined: 1 Jul 2009 10:30:10
Messages: 3
Offline

We've installed the latest Postgres 8.4 Windows-Version.
But in pgAdmin the Debugger-Menue is disabled?

Regards -Stefan Wolf-
Ashish _K

Member

Joined: 4 May 2009 06:59:52
Messages: 41
Location: Pune India
Offline

Hello Stefan

To enable pl/pgsql Debugger follow the following steps:
-----------------------------------------------------------------------------

1. Edit the postgresql.conf file in the data directory and modify the shared_preload_libraries config option to look like the following,

Windows:

shared_preload_libraries = '$libdir/plugins/plugin_debugger.dll'

2. Restart the PostgreSQL server.

3. Run <Installation directory>/share/contrib/pldbgapi.sql on Windows in the database you wish to debug using psql or the pgAdmin query tool.

--Ashish



--Ashish
[Email] [Yahoo!]
Stefan_W

New member

Joined: 1 Jul 2009 10:30:10
Messages: 3
Offline

Now it works - THANK YOU!
jacobus_vvconsult_co.za

New member

Joined: 11 Aug 2009 03:57:04
Messages: 4
Offline

I'm having the same problem with pgadmin. I'm trying to debug a stored procedure and I need to step through my code to find a logical error. I can't find any option related to debugging. I'm running postgres plus standard server 8.4 and pgadmin III v1.10. I've followed all instructions but yet no debugger. (Need some clarity with regards to how I can run pldbgapi.sql on the DB) Do I just run the script in pgadmin in the query editor in pgadmin (This is what I did) or do I need to specify additional detail? Your help will be appreciated.

Regards
Jacobus

Ashish _K

Member

Joined: 4 May 2009 06:59:52
Messages: 41
Location: Pune India
Offline

You need to run pldbgapi.sql in the database where in you want to enable the debugger. You can run it through pgadmin or psql prompt.



--Ashish
[Email] [Yahoo!]
jacobus_vvconsult_co.za

New member

Joined: 11 Aug 2009 03:57:04
Messages: 4
Offline

OK. I've ran the script and I can now see that the debugging functions have been added to my database. Now where can I launch the pl debugger? I can't seem to find that option in pgadmin.
Ashish _K

Member

Joined: 4 May 2009 06:59:52
Messages: 41
Location: Pune India
Offline

Right click on the PLpgSQL function and select debug option from the that menu



--Ashish
[Email] [Yahoo!]
jacobus_vvconsult_co.za

New member

Joined: 11 Aug 2009 03:57:04
Messages: 4
Offline

This is what my menu looks like when I right click my stored procedures:
Refresh
------------------
New Function...
Delete/Drop
Drop Cascaded
------------------
Create Script
Reports
Restore
-----------
Properties
------------

No debug option

Ashish _K

Member

Joined: 4 May 2009 06:59:52
Messages: 41
Location: Pune India
Offline

What is the language of function ? is it plpgsql?



--Ashish
[Email] [Yahoo!]
jacobus_vvconsult_co.za

New member

Joined: 11 Aug 2009 03:57:04
Messages: 4
Offline

Last 3 lines of the SP:

LANGUAGE 'plpgsql' VOLATILE SECURITY DEFINER
COST 100;
ALTER FUNCTION sp_iu_pcs_contact(integer, character varying, character varying, character varying, character varying, character varying, integer, character varying, boolean) OWNER TO dbadmin;

So I'm clueless. I don't know if i'm missing something. My .conf file shows the correct info. The debugger functions have been added. What else can be wrong?

This message was edited 1 time. Last update was at 11 Aug 2009 05:23:52

Ashish _K

Member

Joined: 4 May 2009 06:59:52
Messages: 41
Location: Pune India
Offline

Hi there,
we have covered everything to enable the debugger . I guess we are missing something silly here.

Please rerun the checks. Are you trying to connect the remote machine with pg admin on another machine?

Have you set the parameter shared_preload_libraries = '$libdir/plugins/plugin_debugger.dll' in the conf file of server you are trying to connect.
have you verified that this file actually present on the given location $libdir/plugins/plugin_debugger.dll



--Ashish
[Email] [Yahoo!]
vjvs_yandex_ru

New member

Joined: 21 Sep 2009 06:55:51
Messages: 1
Offline

Hi!
I can add pdDebugger and I see it, but, when I choose "Debugging -> Debug", I see debug window and then the error "An error has occurred: " (and that's all). After that I try to close debug window and pgAdmin crashed.

How can I "cure" it?

This message was edited 2 times. Last update was at 22 Sep 2009 00:54:15

Patricia_LaRue

New member

Joined: 22 Sep 2010 14:00:58
Messages: 1
Offline

jacobus_vvconsult_co.za:

Did you ever manage to get the debugger working? I am having the same problems. I followed the directions and made sure the dll is located in lib\plugins dir. Still Tools/Debugging is disabled.

Anybody out there have any ideas?

Thank you.
Ugo_Paternostro

New member

Joined: 7 Oct 2010 09:04:59
Messages: 1
Offline

Make sure the role you are using to connect to the db has SUPERUSER grants, i.e.:


 
Forum Index » PostgreSQL Installers for Windows, Linux and OS X
Go to:   
Powered by JForum 2.1.8 © JForum Team